SofTest Now Supports Mavericks

download (6)

Are you planning on using ExamSoft’s SofTest exam taking software for final exams this Fall 2014 term? Did you recently upgrade to Mac OS X 10.10, Yosemite? If you read our last post, you were hopefully waiting to install Yosemite until it is supported by ExamSoft. Remember, DO NOT download any new version of Mac OS until you have verified that it is supported by ExamSoft.

Good News, your wait is over! Yosemite is now supported by ExamSoft. You can upgrade to the newest Mac OS Yosemite starting and the new OS will be compatible with the latest version of SofTest.

Before attempting to take any exams, please verify that you have the latest SofTest version, and as always, work through a Mock Exam to ensure proper use of the software before your exams.

For more information, and to see what others are saying about this and other exciting ExamSoft announcements, please visit the ExamSoft Community.